i We use Google Analytics to understand how customers use PROS software and services. For more information about how we use Google Analytics and how you can opt out, please visit here. By continuing to view this page or closing this banner, you accept these terms.
RTDP - RTDP microservices restart
Incident Report for PROS
Resolved
PROS team would like to inform you that between 00:04 UTC and 04:15 UTC, PROS monitoring tools detected multiple service restarts for the different RTDP microservices. An initial assessment has shown that there was no impact on Availability/Sell requests due to the RTDP High availability and redundancy setup. At this point, no further RTDP services have experienced further issues.
By 04:15 UTC all services were brought back up and running. We will continue monitoring the performance in case we detect any issues.
Posted Mar 30, 2021 - 04:37 UTC
Monitoring
PROS team would like to inform you that between 00:04 UTC and 04:15 UTC, PROS monitoring tools detected multiple service restarts for the different RTDP microservices. An initial assessment has shown that there was no impact on Availability/Sell requests due to the RTDP High availability and redundancy setup. At this point, no further RTDP services have experienced further issues.
By 04:15 UTC all services were brought back up and running. We will continue monitoring the performance in case any further issues occur.
Posted Mar 30, 2021 - 04:36 UTC
Identified
PROS team would like to inform you that since 00:04 UTC, PROS monitoring tools detected multiple service restarts for the different RTDP microservices. An initial assessment has shown that there was no impact on Availability/Sell requests due to the RTDP High availability and redundancy setup. At this point, no further RTDP services have experienced further issues.
By 04:15 UTC all services were brought back up and running. We will continue monitoring the performance in case any further issues occur.
Posted Mar 30, 2021 - 04:34 UTC
Update
PROS team would like to inform you that since 00:04 UTC, PROS monitoring tools detected multiple service restarts for the different RTDP microservices. An initial assessment has shown that there was no impact on Availability/Sell requests due to the RTDP High availability and redundancy setup. At this point, no further RTDP services have experienced further issues and we will continue to monitor closely.
Posted Mar 30, 2021 - 03:33 UTC
Investigating
PROS team would like to inform you that for the last 1 hour, started around (23:00 UTC), PROS monitoring tools detected multiple service restarts for the different RTDP microservices. An initial assessment has shown that there was no impact on Availability/Sell requests due to the RTDP High availability and redundancy setup. At this point, no further RTDP services have experienced further issues and we will continue to monitor closely.
Posted Mar 30, 2021 - 00:21 UTC
This incident affected: [Travel Platform] Real Time Dynamic Pricing (EU1, EU2).